Installing XenServer Tools on Openfiler

XenServer 5.6, Openfiler 2.3

Mount the XenServer Tools ISO:
[root@openfiler Linux]#cd /
[root@openfiler Linux]#mkdir /cdrom
[root@openfiler Linux]#mount /dev/xvdb /cdrom
[root@openfiler Linux]#cd /cdrom/Linux

Install dependencies:
[root@openfiler Linux]# conary update beecrypt=contrib.rpath.org@rpl:devel
Preparing changeset request…
Including extra troves to resolve dependencies:
    icu:data=3.4-5.2-1 icu:lib=3.4-5.2-1
Applying update job:                               
    Install beecrypt(:devel :devellib :doc :lib :python :runtime)=4.1.2-2-1
    Install icu(:data :lib)=3.4-5.2-1        
[root@openfiler Linux]# conary update rpm=rpm.rpath.org@rpl:devel/4.4.4
Including extra troves to resolve dependencies:
    neon:lib=0.24.7-5-0.1
Applying update job:                               
    Install neon(:lib)=0.24.7-5-0.1
    Install rpm(:devel :devellib :doc :lib :perl :python :runtime)=4.4.4-1-1

Install the Tools:
[root@openfiler Linux]#cd /cdrom
[root@openfiler Linux]# rpm -ivh –nodeps xe-guest-utilities-5.6.0-578.i386.rpm
error: can’t create transaction lock on /
Preparing…                ########################################### [100%]
   1:xe-guest-utilities     ########################################### [100%]
[root@openfiler Linux]# rpm -ivh –nodeps xe-guest-utilities-5.6.0-578.i386.rpm
error: can’t create transaction lock on /
Preparing…                ########################################### [100%]
package xe-guest-utilities-5.6.0-578 is already installed
[root@openfiler Linux]# rpm -Uvh –nodeps xe-guest-utilities-xenstore-5.6.0-578.i386.rpm
error: can’t create transaction lock on /
Preparing…                ########################################### [100%]
   1:xe-guest-utilities-xens########################################### [100%]
[root@openfiler Linux]# rpm -Uvh –nodeps xe-guest-utilities-xenstore-5.6.0-578.i386.rpm
error: can’t create transaction lock on /
Preparing…                ########################################### [100%]
package xe-guest-utilities-xenstore-5.6.0-578 is already installed

Enjoy: